Blank screens on Discourse


#1

Just ran into a weird problem. I just did a fresh computer build / install, and for whatever reason I now only get a blank white page on anything Discourse related. I don’t think I’ve missed any plugins or anything (like Java etc.) and I migrated my previously perfectly functioning browser profile over. Nothing, not even in safe mode or a full reset. Palemoon 25.7.3. tracert seems to get thru, albeit with one or two timeouts along the way. (both for site + cdn) I did install IE11 (OMG I know!) and got in that way. Perhaps I need to sober up because I’m missing something obvious, but hey there’s lotsa fellow geeks here so maybe you’ll point out something I shoulda caught.

:blush:


#2

My best guess would be Javascript is disabled, although I would expect an error message instead of blank screens… it’s possible some specific resource site is blocked.

What browser are you (normally) using?


#3

It’s enabled and updated. Maybe a coffee will help.


#4

I see, I’ve never heard of that so it didn’t register as a browser.

And of course my company blocks the entire page so I can’t even look at it.

It works with IE11… maybe try different versions of Palemoon.


#5

I’ve seen a similar problem when I browse Discourse from 2 different machines (both behind the same NAT), although it’s working fine for me ATM. Do you have your old system still up and running logged in to Discourse?


#6

No, I’ve replaced the old system (upgraded some things). Same IP etc, same settings + plugins that worked perfectly on Saturday. Doesn’t work now, not with re-installing or safe mode etc. Weird.

I saw similar issues reported when browsing around the net, but it was mostly dev issues with their own discourse instances, not so much users. Never found a clear answer. :confused:

@Telos - Palemoon is a Firefox fork, essentially. I’ve never had issues with it in the year or two I’ve been using it. I much prefer it to all other browsers out there right now. YEMD

[EDIT] Created a new blank profile > started PM using it > close PM > switch back to original profile > Discourse now works. :confused: All good now, don’t ask me why the hell that worked.


#7

Sounds like what you did basically turned your discourse off and on again. Fixing tech is all about finding the correct part to turn off and on again.