If this forum is running slowly for you


#1

I use FireFox on Mac, and the forum has frequently been unbearably slow. I finally decided to start troubleshooting, and believe I’ve nailed it. It appears to be related to “hardware acceleration” which FF uses by default (maybe other browsers do too, I’m not sure).

If you use Firefox and notice it’s very slow to open thread, reply to things, etc. try this:

Tools > Options > Advanced > General > Browsing: disable “Use hardware acceleration when available”

If you’re on Mac, it’s under Preferences not Tools.

The forum is like greased lightning now. Everything happens in under a second, it’s great.


#2

Can’t say I’ve had the same problem, and I’m also using Firefox on OS X. Do other Discourse forums also perform slowly for you? (You can check http://try.discourse.org or http://meta.discourse.org, or my own little forum, or BoingBoing).

Discourse relies heavily on client-side javascript, and so if you have any firefox addons installed that do anything with scripting, they might be screwing things up.


#3

Aha… yeah I do web dev so I have all kinds of stuff like Firebug and others. Maybe that’s the ticket. Oh well, I’m just glad this is running smoothly now, this is the only discourse forum I’ve ever used/seen.


#4

I’ve used a couple of discourse forums and this is the only one that had caused me any problems. @vanclute’s solution has definitely resolved that. I’m still not sure why only this instance of discourse would cause problems when the others didn’t.


#5

This forum has one strange effect when I visit thread a time. It lags and evenually freezes entire firefox unless I close tab and visit forum. It somehow resets. I guess something is really leaking badly in soylent discourse.


#6

I am not sure if this has the same effect as the GUI option, but if you toggle “layers.acceleration.disabled” to “true” in the “about:config” page it should help with certain pages freezing or performing slowly.


#7

The only issue I’ve had with Discourse was when my KBL SSL Enforcer extension yesterday decided to just show a blank screen ol all Discourse fora. Doesn’t matter if a site was whitelisted or blacklisted, as long as KBL was enabled in Chrome, nothing displayed on the screen. If I viewed the source, it was all there. Maybe I’ll try the HTTPS Everywhere.


#8

For whatever it’s worth, I’ve decided to see if I can transition to Safari as my main browser, as FireFox is just WAY too much of a memory pig these days (3GB or more in use is very typical). Safari is proving to have a WAYYYY lighter memory footprint, and also is much much much much faster on this forum in particular. Like night & day. So for those who have a Mac, you might want to try Safari if you don’t already. Or at least something other than FireFox.

I’m so annoyed at what FF has become. But that’s another rant.


#9

Firefox has had issues with the Adblock Plus extension. I had to uninstall it on Chrome as well because it kept crashing when viewing PDF’s.
https://blog.mozilla.org/nnethercote/2014/05/14/adblock-pluss-effect-on-firefoxs-memory-usage/


#10

Yeah I don’t use any adblockers, but in general I just find FF to be super leaky. Didn’t used to be this way years ago.


#11

I use Safari on Mac. Recently my Safari ran more slowly than ever before. I think the reason why my Safari run slower and slower is that I haven’t clear up caches and history files for a long time. So I went to remove them on my Mac. Here are what I did to delete Internet junks.

Open up Safari > Click on Safari in the menu > Click on Clear History and Website Data…
Go to Safari > Preference… > Advanced > Check “Show Develop menu in menu bar” > Click on Develop menu > Click on Empty Caches.