Post access trouble


#1

@codinghorror, the past couple of days I’ve been having trouble accessing posts. When I click on a topic, I get an infinitely spinning wheel. I was able to open a few threads last night, but during the day yesterday and now again today I cannot get into any of them.

I expect the problem may be with my phone (chrome on android), though I hadn’t made any changes when the problem started, I have cleared my browser data since with no luck. I just wanted you to be aware in case it is something on your end.


#2

I had this happen to me during the same time period. Mobile only. Haven’t seen it happen today, but I’ve only used it on my phone a handful of days.


#3

Me too. My impression was that certain posts – the latest ones – were worst. I couldn’t get into this thread, for example. I tried different browsers and different Android devices. I’m glad I can get into it now!


#4

This is still an ongoing problem for me. Sometimes I can access the posts, but often they will not load. Any insight @codinghorror ?


#5

As a followup, it is still happening today for me.

The list pages (unread, new, etc) load fine, but none of the topics load (that I’ve tried). If I go to them from the list pages, it just sits in “loading” forever. If I refresh or otherwise access the page directly, it just renders a blank page.

Still mobile only. Desktop continues to work correctly.


#6

Can you provide more detail? What browser, OS, etc?


#7

I’m using Chrome on Android.

Chrome v39.0.2171.93

Android v4.4.4

@livingparadox @geneven What are you using?


#8

Hmm I am typing this from Nexus 7 and Chrome Android (4.4) and I can’t seem to repro the endless spinning when entering topics. Any step by step repro?


#9

I just came in with my phone too, it’s been an inconsistent issue, sometimes things work, sometimes they get stuck. Over the weekend it seemed to work better (though not well) in the evenings, during the day I couldn’t access any threads. I was having intermittent issues today as well, but it had seemed better today than the last couple of days.

I also noticed that sometimes I could access a thread through the main page, but it would get stuck if I tried to access the same thread though my notification bubble, other times it would get stuck no matter where I clicked through.

Note 4 if it matters.


#10

Nexus 7 and Chrome are also what I’m using, among others. The step-by- step on my Moto X and on my Nexus 7 and on my older Acer tablet are: reboot. Do anything. Go to discourse.soylent.me. Try to open any thread. Do this series when the problem is happening, not when it is not happening. Result: perpetual spinning. Does this help?


#11

@codinghorror

I have not been able to sign in on my phone since maybe last Friday.

iPhone 5s
iOS 8.1.2
Safari


#12

In my case, the problem appears to be that it doesn’t work on Chrome beta. Regular chrome worked for me when I tried it. I guess I’ll go back to non-beta for the time being.

Yep. Having zero problems with non-beta chrome. Not sure what’s happening with kennufs, though, as he’s using the normal one.


#13

Good news! We figured out the bug. We can’t deploy right at the moment as we are waiting for a big dependency change to stabilize, but this should be resolved by the end of the week. Sorry about that!

cc @eviltrout


#14

Awesome to hear! Especially since I tend to only come here through my phone. :smile: